Results 1 to 4 of 4
  1. #1
    Administrator Array
    Join Date
    Mar 2011
    Location
    Dublin, Ireland
    Posts
    76,146

    Game Boy Advance SP - No Audio/Sound Fix

    If you've got a GBA SP that works fine apart from it not outputting any audio from the speaker then this guide might help you out.

    The Problem:


    This is a common enough problem with the GBA SP and is easily fixed if you don't mind opening up the device.

    To start with you'll need a Tri Wing screwdriver to open the case and also a standard small Phillips headed one to remove a few small screws inside the case as well as the battery door.

    Tri Wing screwdriver
    Name:  triwing.jpg
Views: 9134
Size:  14.9 KB

    You will definitely need the Tri Wing screwdriver for this repair but you don't have to spend a lot of money to buy one. I usually get these kinds of tools and other bits and pieces from Rewind Bits as they're UK based(which is close to me here in Ireland so postage isnt a lot) and the quality of their tools is usually better than the cheap crap you find on ebay.

    Here's a link to the tool I used for this repair. It only cost .99p(about 1.20 or $1.60US) and works just fine.
    Rewind Bits - Tri Wing Screwdriver

    If you want to spend a bit more and get a tool kit then you could get the 28 piece kit they sell and you'll be sorted for this repair and any mods or repairs in the future on pretty much any console or computer(you'll also need a Dremel for serious modding).
    Rewind Bits - 28 Piece Tool Kit

    I suppose I should also mention that I've no links or affiliations to Rewind Bits, I'm just a happy customer.

    Right so first of all you'll need to open up the case.
    Remove all the screws that the red arrows are pointing to with the tri wing screwdriver.
    The screw in the middle is the battery cover and that needs to be removed with a standard small Phillips head screwdriver.





    Once all the screws are removed and you've taken the battery cover off(and the battery out) you still need to remove one small tri wing screw.
    It's marked with another red arrow in the below picture(I'd already removed it when this pic was taken).




    Now we can carefully open the case(the plastic power button might fall out at this stage, just put it to one side and we'll put it back in when putting everything back together.)




    Remove the 3 screws marked below with your Phillips screwdriver.




    Once the screws are removed carefully pull the board away from the case remembering that it's still connected to the screen via a ribbon cable(that we dont want to force or break).




    As you can see in the picture above I've removed all the buttons and the rubber parts that cover them. Just put these aside(with the plastic power switch) until later.
    The speaker that's been causing the problem is the circular thing in centre of the plastic section above. It's not held in my anything so will just pop out.

    But before we get to the speaker there is something else we might check while we're inside the case. The video ribbon cable I mentioned earlier can become loose or dislodged from its connector and cause another issue that some people have with their GBA SP, blank screen on power on.

    You can see in the image below the cable is not sitting in the connector properly(I didn't do this as an example, it was really loose).
    The video is fine on this GBA SP but its no harm to reseat the cable anyway and maybe avoid another problem further down the line.
    So, there are two small tabs on each side of the connector. Just click them away from the connector socket and they will open, push the ribbon back in and re-click them. That's it.

    (Click the picture for a bigger version to see the details)



    Now on to the speaker itself. If its still sitting in the case as it is below just pop it out(it should come out easily as its not held in with anything).




    What we're interested in is those two metal flaps/prongs as that's where the problem lies.
    Using a flat-head screwdriver or something similar put it under the flaps and bend them up a little bit so they make better contact with the main board when the case is closed(bending them up about a 1 or 2 mm should do the trick).

    The problem was that these had become to flat over time and weren't connecting with the main board properly, hence the lack of sound.
    If you notice some green stuff on them or if the appear a bit grubby them just clean them with a small piece of cloth or cotton wool bud(or Q-tip to our American cousins). If the dirt wont come off use a very small dab of WD40 on the bud and that should do it.





    Once you're happy that the flaps/prongs are clean and bent up enough to touch the main board you can re-attach the board to the case. But first put your buttons back in(Nintendo have designed them so each button should match up with the slot it's supposed to go in).

    Once the board is re-attached and you have the 3 Phillips screws back in you can test to see if the sound works before putting the case back together. Get the battery and press it against the battery terminal on the board(the yellow arrow is pointing to it below) and turn the power switch on. The GBA SP will power up and you should hear the start-up sound. If not go back and check you pushed the speaker flaps/prongs up enough(and that the volume is up full).




    Once you're happy that the sound is working its time to put the case back together. Just follow the guide above in reverse and you'll be fine. Remember to put the plastic power switch back in before closing up the case.

    That's pretty much it.
    I hope this helps someone out as I couldn't find any repair guide for this problem(I'm sure there are some I just couldn't find any) when I went looking the other day.

    The Result:
    Last edited by RetromanIE; 25-03-2015 at 07:21.
    .

  2. The Following User Says Thank You to RetromanIE For This Useful Post:

    S0nic (17-04-2014)

  3. #2
    i do everything like you write but still not have sound on SP gameboy, i get sound on 2-3 second's and then stop again

  4. #3
    Quote Originally Posted by S0nic View Post
    i do everything like you write but still not have sound on SP gameboy, i get sound on 2-3 second's and then stop again
    You're getting even further than me to have it for two to three seconds. My speaker is very faint. I've replaced the speaker, I've used a meter to check and confirm an 8 Ohm resistance on the speaker, I've bent the connections like this article suggests, nothing...

    It would seem that the problem lies with the circuity or the actual volume control. I've been searching online for 6 months to a year and haven't been able to find anything on how to do this repair.

    Hopefully there is an easy fix to this otherwise the system will make for a good paperweight.

  5. #4
    Administrator Array
    Join Date
    Mar 2011
    Location
    Dublin, Ireland
    Posts
    76,146
    I dunno guys, maybe the capacitors might need to be replaced on your consoles? It's pretty unlikely on these handhelds as it's usually a problem with older ones like the Sega Game Gear or Nomad and I've never had any caps go in a Nintendo handheld before myself. Or it could be the potentiometer(volume adjust) as well.

    What's the sound like with headphones?
    .


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •